%

Nginx : Erreur 403 Forbidden

Comment résoudre l'erreur 403 - Error 403: Forbidden - pour nginx

Détails relatifs à l'article

Article publié, le
et modifié le
Une minute de lecture

Cet article contient 162 mots.

Identifiant de l'article : tag:doc.huc.fr.eu.org,2020-08-22:/fr/web/nginx/nginx-error-403-forbidden


Source brute de l'article :
Commit version : 9bf3d7b


Cet article est aussi disponible sur le protocole Gemini :
gemini://gmi.it-log.fr.eu.org/fr/web/nginx/nginx-error-403-forbidden.gmi


Description

Il peut y avoir plusieurs raisons pour laquelle nginx affiche une erreur 403. Le serveur comprend la requête mais refuse de répondre au client web.

Les raisons :

  1. Une mauvaise configuration du chemin vers le fichier de configuration du contexte server.

  2. Un problème de droits sur le système de fichiers de la racine web, généralement /var/www/.

Par exemple, quelques lignes de log d’erreur :

2020/08/22 10:50:18 [error] 77863#0: *2 directory index of "/htdocs/" is forbidden, (…)
2020/08/22 10:52:21 [error] 890#0: *1 open() "/htdocs/robots.txt" failed (2: No such file or directory), (…)

Vérifiez :

  1. Les écritures des chemins web. Exemple dans le fichier de configuration principal de nginx, les include vers sites-enabled sont ils corrects ?
    Il suffit d’une erreur de typographie…

  2. La racine web doit avoir, normalement pour droits utilisateurs, les noms utilisateur et groupe web… www-data:www-data, ou www:www
    sauf cas particulier, tel sous OpenBSD root:daemon\

  3. Les droits systèmes devraient être de type 0755.

Une fois la situation rétablie, redémarrer/recharger nginx.



Enjoy-ID!
Enjoy-IT!